Changes between Version 2 and Version 3 of Howto/PreventGtkMessageLibGailWrongElfClass


Ignore:
Timestamp:
17/04/08 07:49:56 (10 years ago)
Author:
tj
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Howto/PreventGtkMessageLibGailWrongElfClass

    v2 v3  
    1010The explanation is buried and not well-explained anywhere - until now. After several hours debugging with `gdb` and research I finally discovered the explanation. 
    1111 
    12 Gtk (Graphics Toolkit) uses environment variables to configure some common settings. Amongst them is the accessibility libraries to be used: libgail (GNOME Accessibility Implementation Library) and libatk-bridge (Accessibility ToolKit bridge). In most user environments you'll find: 
     12Gtk (Graphics Toolkit) uses environment variables to configure some common settings. Amongst them is the accessibility libraries to be used: libgail (GNOME Accessibility Implementation Library) and libatk-bridge (Accessibility !ToolKit bridge). In most user environments you'll find: 
    1313{{{ 
    1414GTK_MODULES=gail:atk-bridge